ドキュメント

Talk:Plugins/Authoring

From jQuery JavaScript Library

Jump to: navigation, search

It might be better to rename this page as 'Plugin Development' or use another common dev-word instead of 'Authoring'. I feel the same about the navigation. 'Authoring' is a creative alternative, but not really preferred. Am I the only one?

I would tend to agree

Yes, I would agree that "Plugin Development" might be a better alternative to "Authoring." Do you think it's causing some confusion right now? That would be the biggest reason for change, in my opinion.

Need a Section Discussing Commenting/Documentation

It'd be great if there were standards for documentation when authoring plug-ins.

And I also agree that perhaps "Authoring" should change.

Is it better to jQuery.fn.extend() ?

Aristotle posted here:

http://scott.sauyet.com/thoughts/archives/2007/03/31/overlabel-with-jquery/#comment-24211

That instead of this:

( function($) { $.fn.overlabel = function() { // ... }; } )(jQuery);

It may be better to write this:

jQuery.fn.extend( { overlabel: function() { // ... } } );

Does anyone know if the latter example is better than the former example?